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Legal Notices 

IRISPowerscan™ Server Users's Guide 

The software described in this document is furnished under a license agreement which states the terms of use 
of this product. The software may be used or copied only in accordance with the terms of that agreement. No 
part of this publication may be reproduced, transmitted, stored in a retrieval system, or translated into 
another language without the prior written consent of I.R.I.S. 

  

Copyright 

© 2019 I.R.I.S. SA All Rights Reserved. 

I.R.I.S. SA owns the copyrights to the IRISPowerscan™ software, the online help system and this publication. 

  

Documentation version 1.0 

The information contained in this document is the property of I.R.I.S. Its content is subject to change without 
notice and does not represent a commitment on the part of I.R.I.S. The software described in this document is 
furnished under a license agreement which states the terms for use of this product. The software may be used 
or copied only in accordance with the terms of that agreement. No part of this publication may be reproduced, 
transmitted, stored in a retrieval system, or translated into another language without the prior written consent 
of I.R.I.S. 

This manual uses fictitious names for purposes of demonstration; references to actual persons, companies, or 
organizations are strictly coincidental. 

  

Trademarks 

The I.R.I.S. logo, IRISPowerscan™ and IRISPowerscan™ Server are trademarks of I.R.I.S. 

OCR ("Optical Character Recognition"), Linguistic technology, ICR ("Intelligent Character Recognition") 
technology, MICR ("Magnetic Ink Character Recognition") technology, BCR ("Bar Code Reading") technology, 

OMR (Optical Mark Recognition), iHQC ("intelligent High Quality Compression") technology and HQOCR ("High 

Quality OCR") technology by I.R.I.S. 

Document Generation by I.R.I.S. 

Send to the Cloud by I.R.I.S. 

All other products mentioned in this User Guide are trademarks or registered trademarks of their respective 
owners. 

  

Patents 

IRISPowerscan™ Server integrates the following patent-granted I.R.I.S. technologies: US8068684; US8331706; 
US8666185; JP5501958; US8995780; EP2143039A2; EP14163365.1; BE1022166; BE1022635; US8913836; 
BE1022630; US8897600; BE1022636; US8811751; US8411940; BE1021013; US9058517; US9183636; 
US9311558; BE1025006; BE1022562; US9798943; BE1024194; US9836646; BE1024836.  
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About IRISPowerscan™ Server 

By means of IRISPowerscan™ Server, Administrators can set up a Client Server Architecture between 
IRISPowerscan™ Server and multiple IRISPowerscan™ Workstations - or Clients on the same LAN network. This 
way the three activities of IRISPowerscan™ - being Capture, Validation and Export - can be divided over 
different Clients and you can set up an entire workflow process. Some users take care of the scanning, while 
others do the index validation and the server does the export (most commonly used). 

  

How does it work? 

1. An Administrator configures a Project that different IRISPowerscan™ Clients will work on. 

2. He exports the project from the standalone application and imports it within the IRISPowerscan™ 
Server application. 

3. He configures the different users and their permissions inside the IRISPowerscan™ Server application. 

4. The users connect their IRISPowerscan™ Client to the IRISPowerscan™ Server using the credentials 
they obtain from the Administrator. 

 

Client-Server overview 

IMPORTANT 

WARNING: Before modifying a project, make sure that no batches are pending for that project. Failing to 
process all the batches before changing a project can lead to random errors. 

• The IRISPowerscan™ Server application must be installed on a computer/server to which all required 
IRISPowerscan™ Clients have access. 

• The IRISPowerscan™ Server application itself can only be accessed via the computer on which it is 
installed, or via standard Remote Desktop Connection. There is no remote control or Web control 
foreseen. 

• The Projects that are shared via IRISPowerscan™ Server cannot be modified via the IRISPowerscan™ 
Server application or by IRISPowerscan™ Clients. These Projects are Read-only. The only setting in a 
Project that can be changed are the Scan Source settings. 
If other modifications need to be made to a Project, an Administrator must: 

• Export the Project from the IRISPowerscan™ Server and import it to an IRISPowerscan™ 
standalone application. 

Note: Standalone implies being disconnected from the Server. Even an Administrator cannot 
modify a Project if his IRISPowerscan™ application is still connected to IRISPowerscan™ Server. 

• Do the required modifications. 
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• Export the Project back to the IRISPowerscan™ Server application. 
The original project on the Server will be overwritten if it has not been renamed. 

• Restart the required IRISPowerscan™ Clients again. 
The modified version of the Project will now be copied to the Clients.  

Note: When working with IPS Server, a Standard Operating Procedure must be in place. The IPS 
server administrator must be trained and must control the daily production. Some project 
statuses or batch statuses may require some attention and appropriate actions.  
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Step 1: Install the IRISPowerscan™ Server 

System Requirements 

WARNING about Virtual Machines: 
Some virtual machines running on a laptop or small computer may not be usable. Some scanners are not 
recognized properly and the IRISPowerscan™ installation may fail if the Virtual Machine is not up to date 
with the latest Windows updates.  
Also note that a Virtual Machine must have at least 4 virtual cores (or vCPU). Should you need adding 
cores, make sure you create a VM with the desired number of cores straight from the beginning (indeed, 
changing the VM’s configuration after first deployment can make the VM unstable)  
If your virtual machine has vSocket and vCore, you must multiply them to obtain the amount of vCPUs. 

 

IRISPowerscan™ Server 

REQUIREMENTS OS CPU RAM HDD 

Minimum for IPS 
SERVER 

Windows 10, 

Windows Server 
2012 R2, 2016 

(64-bit) 

At least 4 processors or 
more.  

IRISPowerscan™ will use 
all available resources. 

The more resources, the 
faster the processing. 

8 GB 

50 GB free hard 
disk space 

preferably on a 
Solid State Disk 

drive. 

Recommended for 
IPS SERVER 

Windows Server 
2019 (64-bit) 

If they are vCPU, it is 
highly recommended to 

have 8.  

(to have the final value if 
you have vSocket and 

vCore, simply multiply the 
number of vCore per the 
number of vSocket to get 
the total amount of vCPU.  

16 GB 

Fast IO is 
highly 

recommended 

100 GB free hard 
disk space 

SSD drives are 
highly 

recommended. 

Fast IO is highly 
recommended 

Network 
requirements 

• Internet connection 

• The Network infrastructure must be reliable and must have a decent 
bandwidth. The performance of the IRISPowerscan™ Client Server is highly 
dependent on the quality and performance of the network and the 
server/computers. 

• The Firewall and anti-virus software should block neither the ICMP ping 
commands, nor the HTTP port on which IRISPowerscan™ Client Server is set 
up. 
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IRISPowerscan™ 

REQUIREMENTS OS CPU RAM HDD 

Minimum for IPS* 

Windows 7, 8, 8.1 

(64-bit)  

Windows Server 
2012 R2, 2016, 

2019**  

(64-bit) 

2.2 GHz processor 8 GB 
10 GB free hard 

disk space 

Recommended for 

IPS* 

Windows 10 

(64 bit) 

Processor Intel i7 or 
similar.  

2.6 GHz or faster, with at 
least 4 cores 

16 GB 

50 GB free hard 
disk space 

preferably on a 
Solid State Disk 

drive. 

Network 
requirements 

Internet connection 

* IPS Standalone, Clients or Unattended 

** WARNING: you won't be able to use a Scanner if you use IPS on Windows Server OS. 
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Installing IRISPowerscan™ Server 

Preliminary note:  

The IRISPowerscan™ Server application must be installed on a computer to which the IRISPowerscan™ Clients 
have access. 

  

To install IRISPowerscan™ Server: 

• Download the IRISPowerscan™ package from the I.R.I.S Partner Portal 

• Double-click IRISPowerscanServer.msi 

• Select I agree to the License terms and conditions. 

• Click Install and follow the on-screen instructions. 

• Click Close to finish the installation. 

  

Note: if you want to use the IRISPowerscan™ Server Service to carry out the Import (Server is selected in 
the Capture activity), for instance to use IRISPowerscan™ Server for Watched Folders, you need to have a 
Speed license (30, 60, 100, 130 or unlimited PPM) on the IRISPowerscan™ Server. This Speed license 
comes with a regular IRISPowerscan™ package. You must select the one that best matches your 
requirements in terms of import speed, output connector and iHQC PDF compression. 

  

To activate this license, simply follow the installation and activation procedure.  

  

https://irisdatacapture.com/portal/
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Configure IRISPowerscan™ Server 

Start the IRISPowerscan™ Server Service 

The IRISPowerscan™ Server Service should start automatically. 

To check if it is started: 

• Open the IRISPowerscan™ Server application. 

• If the traffic light icon in the bottom ribbon is green, the service is started. 
If the traffic light icon is red, click it to start the service. 

 

WARNING: When setting up your users, groups and projects on the server, we recommend you to stop 
the IRISPowerscan™ Server Service. Once all your settings are correct and ready, then you can start the 
IRISPowerscan™ Server service. 

  

Open the Required Port 

By default, TCP port 8080 must be open on the IRISPowerscan™ Server in order for Clients to connect to the 
Server. 

If that port is used by another application, you can configure IRISPowerscan™ to use a different one. 

To change the port: 

• Start the IRISPowerscan™ Server Service as described above. 

• On the computer where IRISPowerscan™ Server is installed, open a browser and go 
to %programdata%\IPS11Server\LocalProjects. 

• Right-click settings.xml and click Edit. 

• Change the serverPort value from 8080 to another one. 

 

• Save the settings.xml file. 

• Click the traffic lights icon again to stop and then to restart the IRISPowerscan™ Server Service. 

Note: if the default port has been changed, the port information must be communicated to the 
different IRISPowerscan™ Clients. They need it in order to connect to the Server. 
The default port does not need to be specified. 
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Step 2: Install the IRISPowerscan™ Clients 

On each computer you want to use as IRISPowerscan™ Client you need to install an instance of the 
IRISPowerscan™ application. 

To install IRISPowerscan™: 

• Download the IRISPowerscan™ package from the I.R.I.S Partner Portal 

• Run the IRISPowerscan.msi. 

• Click Next and follow the on-screen instructions. 

• Click Finish to finish the installation. 

Tip: you find your activation code in the email you received from I.R.I.S. 

  

https://irisdatacapture.com/portal/
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Step 3: Configure a Project on the IRISPowerscan™ 
standalone application 

How to configure a Project is explained in the IRISPowerscan™ User Guide and How To Guide. 

WARNING:  
The Project can only be configured in the IRISPowerscan™ standalone application - when it is 
disconnected from the IRISPowerscan™ Server. 
It cannot be configured within the IRISPowerscan™ Server application or on IRISPowerscan™ Clients that 
do not have Administrator rights. 
If changes ever need to be made, export the Project from the IRISPowerscan™ Server application and 
import it again in the IRISPowerscan™ standalone application, where an Administrator can modify it. 

  

Export the Project 

When you are done configuring the Project in the standalone application, export it. 

• In the IRISPowerscan™ standalone application, click File > Open. 

• Select the Project you want to export. 

 

• Click the up arrow to export the project. 

• Store it in a location to which you have access from the IRISPowerscan™ Server. 
The project will be stored as .zip file. 
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Step 4: Configure the user groups on the IRISPowerscan™ 
Server 

In order for IRISPowerscan™ Clients to connect to the Server and access shared projects, they need the 
necessary user permissions and credentials. You can configure the user permissions, assign users to a group 
and determine their credentials with the IRISPowerscan™ Server application. 

Creating User Groups 

The user permissions are defined in the Groups section. Each user belonging to the same group has the same 
permissions. This way you avoid having to configure the permissions for each user separately. 

To create a user group: 

• Open the IRISPowerscan™ Server application. 

• In the Home tab, select Groups and click Create. 

• The new Group is added to the Groups list. 

• Double-click the new group to edit its Permissions. 
Or select it and click the Edit button. 

 

Creating user groups 

• Select the required Permissions from the list and click OK. 

• Administrate: user may access the Users, Groups and Batches sections in the 
IRISPowerscan™ main application's Application menu. 

Tip: do not enable this option for Clients. 

• Delete Project: user may delete projects. 

• Export Project: user may export projects so they can be used in other workstations or by the 
IRISPowerscan™ Server. 

Tip: do not enable this option for Clients. 

• Settings: user may modify the settings of the input source. 

• Create batch or document: user may create new Documents and Batches. 

• Delete: user may delete elements. 

• Undelete: user may undelete Pages that are marked for deletion. 

• Split: user may split batches and documents. 

• Merge: user may merge batches and documents. 

• Reorder: user may reorder the pages. 
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• Cut: user may cut elements. 

• Copy: user may copy elements. 

• Paste: user may paste elements. 

• Swap: user may swap the sides of a Duplex page. 

• Attach: user may attach pages. 

• Detach: user may detach pages. 

• Rotate: user may rotate pages. 

• Crop: user may crop the size of pages. 

• Fill: user may fill parts of the pages. 

• Customize: user may customize the view of the projects. 
(by means of the Show/Hide tools on the View tab) 

• Designer: not relevant in client-server mode. No impact. 

• Now you must add at least one User to the Group. 

  

Note that there are also two default groups: Supervisors and Operators. 

The Supervisors group has access to all permissions. In other words, Supervisors can do all configuration 
actions. The permissions of the Supervisors group cannot be modified. 

The Operators group is by default allowed to scan and process documents in IRISPowerscan™ but cannot do 
advanced configurations. The permissions of the Operators group can be modified. 

Creating Users 

To add a user to a group: 

• Select Users and click Create. 

 

• The new User is added to the Users list. 

• Double-click the new user to edit its Settings. 
Or select it and click the Edit button. 

• Enter a Name for the new user. 

• To apply a password, click Change password.  
If this is the first time you attribute a password, leave the Old Password field empty, enter the 
password in the New Password field, and confirm it. 

• To change the default user icon, select another icon from the list. 

• If the user is/should be part of a domain, enter the domain in the Domain field. 

• The Status of the new user is by default set to Active.  
To deactivate the user later on, return to this menu and select Inactive. 

• Select the interface language from the Language list. 
When the user logs in, the interface is displayed in the selected language. 

• Select the Unit in which measurements must be displayed: centimeter, inch or pixel. 

• Select the Group to which you want to add the user. 
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• Once you have created a user in IRISPowerscan™ Server, he can connect his workstation to the Server 
and log in using his credentials. 

Note that there are 2 default Users in IRISPowerscan™: guest and SysAdmin. Both belong to the Supervisors 
group and therefore have all Permissions. 

Tip: we recommend you to create new groups and new users that best describe your application. 
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Step 5: Import the Project into the IRISPowerscan™ Server 

• Start the IRISPowerscan™ Server application. 

• Click Projects. 
If you are using IRISPowerscan™ Server application for the first time, the Projects list should be 
empty. 

• Click Import. 
Now browse for the project you exported from the IRISPowerscan™ standalone application. The 
project is in the .zip format. 

• Then select Open. 

 

Determine which User Groups may carry out which activity: Capture, Validation, Export 

• In IRISPowerscan™ Server click Projects. 

• Double-click the Project you configured. 

• Select which activity should be carried out by which User Group. 

Note: if you choose Server as Group, the activity will be carried out by IRISPowerscan™ Server in 
the background, and will not require a user intervention.  
We recommend you NOT to assign an activity to Service, but instead to a group or server. 
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Step 6: Connect Client to the IRISPowerscan™ Server 

In order for users to collaborate on projects that are managed by the IRISPowerscan™ Server, they must 
connect their IRISPowerscan™ Client to the IRISPowerscan™ Server and log in using the credentials that were 
specified in the IRISPowerscan™ Server. 

  

Step 1: Connect an IRISPowerscan™ Client to the IRISPowerscan™ Server 

• Open the IRISPowerscan™ Client 

• Click File > Info > Generalities. 

• In the IRISPowerscan™ 11 Server section, enter the address where the IRISPowerscan™ Server is 
installed. 
For instance jsmith. 

• Then click Connect. 

 

• When the connection is established, click Restart now to restart the application. 

You can check on the client-server connections in the Users configuration: 

 

Step 2: Log in from the IRISPowerscan™ Client 

• Open the IRISPowerscan™ Client. 

• Click File > Login. 

• Click Yes to restart the application. 

• When the application restarts, enter your Domain\Username and Password and click OK. 
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• Select the Project you want to open. 
The Projects that are listed here are the ones managed by the Server. 

Note: a Client only sees the Projects to which he has access. 

• Carry out the actions for which you have permissions and click Process to go to the next step of the 
process. 

Note: when processing heavy batches, it may take some time for the batches to be moved to the 
next step. 
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Workflow Example 

In this section we provide an example of workflow of how different IRISPowerscan™ Clients can collaborate 
using a shared project. 

In our workflow, Client 1 does the Capture, Client 2 does the Validation, and the Export is done automatically 
by the Server. 

WARNING:  
Do not change a project when batches are pending  
Stop the service when changing groups, users or projects. 

  

IRISPowerscan™ Server Configuration 

Create the required user group and user in IRISPowerscan™ Server 

• Add the group "Group - Capture", add "User 1" to the group "Group - Capture" and assign a password. 

• Add the group "Group - Validation", add "User 2" to the group "Group - Validation" and assign a 
password. 

See Define Groups and Users if necessary. 

Share a project on which you want the Clients to collaborate 

• Configure the project in the IRISPowerscan™ standalone application, export the project and import it 
into the IRISPowerscan™ Server application. 

• Open the imported project in IRISPowerscan™ Server and specify which activity should be carried out 
by which User Group. 
In our example select: 

• Select "Group - Capture" in the Capture list. 

• Select "Group - Validation" in the Validation list. 

• Select "Server" in the Export list. 

 

• When the configuration is done, click the traffic lights icon in the bottom left corner to start or restart 
the IRISPowerscan™ Server Service. 
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Workflow 

User 1: does the Capture 

• Start the IRISPowerscan™ Client. 

• Connect the Client to the Server via File > Info > Generalities. 

 

• Go to File > Login and enter your credentials. 

 

• Open the shared project and click Scan. 

 

  

Tip: to check the status of the batches, go to File > Manage. The batches in progress are listed. 

 

Notice the 3 tiny LEDs next to the Batch icon. They indicate the different steps: Capture, Validation and 
Export. Each of the LEDs also indicates the status of the corresponding activity in a different color: 

• Grey: activity is not started. 

• Orange: ready to be processed. 

• Orange (blinking): in progress. 

• Green: completed. 

• Red: in error. 

So a batch with the leds green, orange and grey means the Capture is done, the Validation is ready to be 
done and the Export is not yet ready. 

  

• When the scanning is done, click Process. 
The task of User 1 is now completed. The batches are transferred to the IRISPowerscan™ Server 
where they are available to User 2 to do the Validation. 
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User 2: does the Validation 

• Start the IRISPowerscan™ Client. 

• Connect the Client to the Server via File > Info > Generalities. 

• Go to File > Login and enter your credentials. 

• Open the shared project. You will notice that the batches that were scanned by User 1 are ready for 
validation. 

• Click Open, select the batch you want to validate and click Open. 

 

• Do the Validation. When you are done, click Process. 
The validated batch will be transferred to the IRISPowerscan™ Server, where it is exported 
automatically to the configured destination. 

Note: if User 2 does not want to do the validation, he can discard the batch to release it for another User. 
To do so, click on the arrow below the Process button and select Discard. 

 

Logs Information 

The Administrator can access the Logs information via the IRISPowerscan™ Server application. There you can 
find the events reporting each Client's actions, their batches and their associated activities. 

Note that Clients cannot access these Server logs, they can only access the information about their own 
batches. 

 



IRISPowerscan™ 11 SERVER - User Guide 

21 

Batch Lifecycle Information 

• All batches and their status can be checked by the Administrator in the IRISPowerscan™ Server 
application via Home > Batches 

 

Tips:  
Double-click a Batch to display its lifecycle information. 
The 3 tiny LEDs meaning. 

• The Administrator has the ability to change the status of a batch, or delete a batch in the 
IRISPowerscan™ Server, if for instance an error occurred. 
To move the batch to a previous step, use the return arrows. 

 

Action buttons (tooltips available in the User Interface) 

Administrators can do the following actions: 

•  Unlock a batch locked by a Client. 

•  Move to validation: move the batch to validation activity. 

•  Move to export: move the batch to export activity.  

•  Show a batch history.  

•  Delete a batch at any stage.  

When Clients are still logged in and connected to the Server, a warning message is displayed as 
soon as a checked out batch is deleted or reset on the server. This warning message appears in 
Navigation mode.  

 

Client side: warning message 

The batch goes back to the previous step and Clients need to perform their task on the batch 
again. 

The Clients, in turn, can do the following actions: 

• Delete a batch (provided they have the Administrate Permission). 

• Redo the Capture. 
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• When a Validator opens a batch for validation, that batch will be locked (greyed out) to other clients. 
If this Validator leaves his computer without completing the validation, the batch will remain in that 
state until either the Validator returns to finish the job or until the Administrator/Production 
Manager* unlocks the batch on the Server and resets it to the "Validation Ready" state. 

* In a Client-Server Architecture it is recommended to have a Production Manager who checks 
the production on a daily basis to guarantee that all batches are correctly processed without 
errors. In case of errors, he must check what happened, take corrective actions, restart the 
processing of the batch, restart the validation or ask for a batch rescan. 

 

 

Example workflow 

 

• If a Client fails or cannot see his batches anymore, the batches are not lost. They are stored on the 
Server as a fail safe mechanism. 

WARNING: the server admin has full powers with NO undo possibilities. That means deleting or changing 
batches, groups or users can lead to data loss if not done carefully and at the right time.  

  



IRISPowerscan™ 11 SERVER - User Guide 

23 

Batch Activity View & Statistics  

IRISPowerscan™ Server brings a new batch activity view and statistics. 

The batch activity view tells you the amount of batches that have been processed, or waiting to be processed 
or in error. 

 

Activity view 

In the project view, you can see some statistics for each one of your projects.  

 

Project view and statistics 

Here are the information you can see for each projects (cf. Glossary):  

BPD (batches per day) 

IPM (images per minute) 

IPD (images per day)  

Avg IPM (average images per minute) 
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Reporting and Exporting Server Statistics 

Under the Info > Generalities tab, you can find the reporting section where you can enter your email settings 
in order to get notifications when fault or project error occurs. 

Under the same section, you can save or reset the server statistics. 

Resetting the statistics flushes all Processed, BPD, IPM, Avg IPM and IPD data 

 

Reporting and Statistics settings 

  

The Export statistics button allows the user to save the data in XML format: 

<Statistics date="9/5/2019"> 

  <Projects> 

    <Project name="Server03" bpd="4" ipd="200" ipm="151" avgIpm="109"> 

      <Total None="0" OnError="1" Processed="4" OnHold="0" /> 

    </Project> 

    <Project name="Server01" bpd="4" ipd="200" ipm="143" avgIpm="108"> 

      <Total None="0" OnError="0" Processed="4" OnHold="1" /> 

    </Project> 

    <Project name="Server02" bpd="4" ipd="200" ipm="126" avgIpm="111"> 

      <Total None="0" OnError="1" Processed="4" OnHold="0" /> 

    </Project> 

  </Projects> 

  <Total None="0" OnError="2" Processed="12" OnHold="1" /> 

</Statistics> 
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Glossary 

A 

Avg IPM: Average images per minute: takes the last 10 processing speeds in IPM and computes the average 
value. 

B 

BPD: Batches per day: counts all processed batches during the last 24 hours. 

I 

IPD: Images per day: counts all processed images per day. 

IPM: Images per minute: is a speed indicator computed during the last processing. It counts all images 
processed per minute. 
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