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How to Create Projects 
To create a new project, click FILE > Create and double-click a template, e.g. Wizard. 

 

Specify a unique Name and an input Source: Scanner, Folders, etc. 

Then click Finish (or Next if you want to change other settings). 

How to Add Image Samples 
In order to define Image Processing or Data Extraction operations, an image sample is needed. 

Select an image in the navigation explorer, and click Copy. 

Go to Designer > Images and click Paste. 

How to Use Image processing 
To add an Image Processing operation, you need an image sample. 

Go to Designer > Operations > Image Processing and click Create. 

Note:  in most cases, the image processing options you select in the settings of your scanner will be 

faster.
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How to Use Data extraction 
To define a Data Extraction operation, you need an image sample. 

Go to Designer > Operations > Data Extraction and draw a zone. 

 

The content of the zone (e.g. FORM) will be stored in the variable Image.Zone1.
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How to Remove Blank Images 
To remove blank images, it is strongly recommended to select the corresponding option at the 

scanner level, i.e. in the settings menu of your scanner. If this option is not available in your scanner 

settings, go to Designer > Operations. Click Create and select Blank Page Detection. 

 

Adjust the Sensitivity or the Size (of the compressed buffer) until the image is detected as blank. 

The variable Image.IsBlank is true when the current image is detected as blank. 

The variable Page.IsBlank is true when both the front and rear images are blank. 

To delete the blank images, go to Designer > Operations, click Create and select Blank Page 

Detection. Then click Operations > Create again, select Page Deletion and add the condition 

Image.IsBlank. 

 

When the condition is true (e.g. Image.IsBlank), the current image is deleted. 

Select the Delete page option to delete both the front and rear images. 



 

 7 

How to Do Page identification 
Go to Designer > Pages, click Create and specify a unique Name for the Page Type. 

The Page Type is uniquely identified when the condition is true. 

 

In the example above, a page is identified as Separator if the value of Zone1 is not empty. 

The Page Type (in this case Separator) is stored in the variable Page.Type. 

The operations in Designer > Pages > Separator > Operations are applied only to the PageType called 

“Separator”. 

Fingerprint 
To enable Fingerprint Detection, go to Designer > Operations, click Create and select Fingerprint 

Detection. Then go to Designer > Pages and click Create. 

Specify the name for the new Page Type, define the Identification method and provide an image 

sample. 
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The result of the Fingerprint detection is stored in the variable Image.Fingerprint. 

Additional image samples can be added in Designer > Pages > Separator > Images. 

 

How to Separate Documents 
To separate the pages into documents, go to Designer > Documents > Document and specify a 

Condition. A new document is created when the condition is true. 

The name of the new document is based on the naming expression. 
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E.g. a new document is created when the content of the zone (Zone1) is “FORM”. The name of the 

new document is the name of the document type (Document.Type) followed by a document counter 

(Document.Counter). 

To create a document for each separator use the condition: Page.Type == “Separator”. 

To create a document for each input file use the following condition and naming: 

Condition: Input.PageIndex == 1 

Naming: Filename(Input.Path) 

Note: scripting can be used to define your own function (like Filename). 

How to Separate Batches 
To separate the documents into batches, go to Designer > Batches > Batch and specify a Condition. A 

new batch is created when the condition is true. 

The name of the new batch is based on the naming expression. 

 

E.g. a new batch is created on the third document. The name of the new batch is the name of the 

batch type (Batch.Type) followed by a batch counter (Batch.Counter). 

Tip: when the Capture is being done by the Service, meaning you are using Watched Folders, enter 

the following condition in the Condition field on Batch level to create one batch per document in the 

Watched Folder: Input.PageIndex==1. Or simply click the Wizard icon next to the Condition field and 

select On every file. 
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How to Do Indexing 
To create a new field at batch level, go to Designer > Batches > Batch > Fields and click Create. 

To create a new field at document level, go to Designer > Documents > Document > Fields and click 

Create. 

Specify a unique Name, a Type and a default Value. 

The condition is used to check the validity of the field. 

 

E.g. the default value of Field1 will be the content of Zone1. The field is valid if it contains exactly 4 

letters. 

The value of the current field is stored in the variable Field. 

Fields at batch level are stored in the variables <batch type>.<field name>. 

Fields at document level are stored in the variables <document type>.<field name>. 

E.g. Batch.Field1 and Document.Field1. 

Matching operator 
The matching operator (^=) is used to check a simplified or a regular expression. 

 Simplified expressions Regular expressions 

One letter A \w 

From zero to three letter(s) A(3) \w{0,3} 

From one to three letter(s) A[3] \w{1,3} 

One digit 9 \d 

Any character X . 

Literal values are enclosed between single quotes.  

The logical operator or (|) can also be used. 

E.g. Field ^= “AAAA|9999” means exactly four letters or exactly four digits. 
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How to Define Outputs 
To define an output, go to Designer > Outputs > Output and specify a Format, a Naming expression 

and one or multiple Destinations. 

 

Images are exported when the condition is true. 

To export only color images use the condition: Image.IsColor. 

To export only the best images (in terms of bit per pixel) use the condition: Image.IsBest. 

How to Use Scripts 
To add your own function, go to Designer > Scripts > Script and click Edit. 

 

By default, the file script.cs (%Appdata%\IPSx\script.cs) is shared by all the projects. 

When you create your own script, it is strongly recommended to put the file in the project folder  

(e.g. %Appdata%\IPSx\Projects\MyProject). 
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How to add the content of Index Fields to the Indexes.xml output file 

using a Script 
In some projects it might be required to store the content of Index Fields to the Indexes.xml output 

file. 

Example: 

IRISPowerscan is used in Client-Server mode to scan and index incoming mails. On one IRISPowerscan 

workstation the mails are scanned, one batch per mail. Once the scanning is done, another 

IRISPowerscan workstation downloads the batches from the IRISPowerscan Server and does the 

Index validation. Once the Index validation is done, the batches are sent back to the IRISPowerscan 

Server for processing. 

By means of a script, we make sure that the name of the Indexer will be stored in the Indexes.xml 

output file. We do this by creating an OnDownload event. As soon as the Indexer downloads a batch 

to do the Index validation, the required content will be inserted in the Indexes.xml output file. 

Configuration: 

• Set up a Client-Server architecture in which one IPS workstation scans the batches and one 

IPS workstations does the Index validation. 

• In the default Document type, create the Index Field “Indexer” and link it to an extraction 

zone. Then enter !IsNullOrEmpty(Field) in the Condition field. 

• Add one Output type in which your documents must be exported. 

Then add a second one and select Indexes.xml as Format. This file will contain the Indexer 

name. 

• Write a script that contains the following content: 

using System; 

using System.ComponentModel; 

using IPSx.Api; 

 

namespace IPSx.Scripting 

{ 

    public partial class Script : IEventListener 

    { 

        public bool OnEvent(string name, object parameter) 

        { 

            if (!string.Equals(name, "OnDownload", StringComparison.InvariantCultureIgnoreCase)) 

return false; 

 

            IPSxNode ipsxNode = parameter as IPSxNode; 

            if (ipsxNode == null) return false; 

 

            string currentUser = string.Empty; 

            foreach (IPSxField ipsxField in ipsxNode.Fields) 

            { 

                if (string.Equals(ipsxField.Label, "CurrentUser", 

StringComparison.InvariantCultureIgnoreCase)) 

                { 

                    currentUser = (string)ipsxField.Value; 

                    break; 

                } 

            } 

             

            foreach (IPSxField ipsxField in ipsxNode.Fields) 

            { 

                if (string.Equals(ipsxField.Label, "IndexerWindows", 

StringComparison.InvariantCultureIgnoreCase)) 

                    ipsxField.Value = Environment.UserName; 

                if (string.Equals(ipsxField.Label, "IndexerIPSx", 

StringComparison.InvariantCultureIgnoreCase)) 

                    ipsxField.Value = currentUser; 

            } 

            return true; 

        } 

    } 

} 
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• Add the script you created to the IRISPowerscan project. 

• Scan and Index your documents. 

• Go to the Output folder, open the Indexes.xml file and check if it contains the Indexer name. 

How to use Data sources 
To create an ODBC datasource, go to Designer > Data sources and click Create. 

Select ODBC as source. 

Then specify a DSN Connection string and an SQL command. 

 

Create a field linked to the data source (DataSource). 
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DataSource1:0:3 means that the value in the first column (ID) will be stored (in Document.Name) and 

the value of the fourth column (LASTNAME) will be displayed. 

To narrow the search, create another field (e.g. Country) and change the SQL command to: 

"SELECT ID, CODE, FIRSTNAME, LASTNAME FROM Table1 WHERE CODE = '" + Document.Country + "'" 

 

Dependency 
Go to Designer > Data sources and create a Data Source of the type List and which contains two 

columns. 

 

Link the data source to a Field (e.g. Field). 
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DataSource1:0:1 means that:  

a) The value in the first column (index = 0) will be stored. 

b) The value in the second column (index = 1) will be displayed. 

Define another Field (e.g. SubFolder). 

 

SubFolder depends on Document.Field. When Document.Field is changed, the value of SubFolder is 

updated by the first column of Document.Field. 

How to Use Cross-linked Index Fields 
In this section we provide a more detailed example of how to use cross-linked Index Fields using an 

ODBC data source. 

In our example we have created an Excel file containing a list of people and their age.  

 

We will create two Index fields in IRISPowerscan, called Name and Age and link those fields to the 

ODBC data source. By filling in their Value fields we make sure that the corresponding Age is 

displayed when a Name is selected and vice versa. 
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Preliminary steps 

Create the ODBC data source: 

• Create an Excel file and name it LinkedFields.xlsx. 

• Fill in the values as shown above. 

Add the ODBC data source to your System DSN: 

• Go to Control Panel > Administrative Tools > Data Sources (ODBC). 

Important: when using a 64-bit Operating System, start Data Sources (ODBC) from 

C:\Windows\SysWOW64\odbcad32.exe. 

• Click the System DSN tab and click Add. 

 

• Select Microsoft Excel Driver (*.xls, *.xlsx, *.xlsm, *.xlsb) and click Finish. 

 

• Enter the Data Source Name. E.g. LinkedFields. 

• Click Select Workbook, and then browse for the Excel file you created. 

• Click OK to confirm. 
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Creating Cross-linked Fields in IRISPowerscan 

• Go to Designer > Data sources. 

• Click Create. 

• Name the data source DataSource, select ODBC as Source and click Next. 

 

• In the Connection string list select the correct database. In our example dsn=LinkedFields. 

 

• Then enter the following SQL command: “SELECT * FROM [Sheet1$]” 

• Click Test to see if it works. 

You should get the following results: 

 

• Now create two index fields for the default Document type. 

• Name the first one Name. 

• Click the down arrow next to the Data source field, and select the data source you created. 

In our example DataSource. 

• Enter “:0” behind the Data source name: DataSource:0. 

:0 stands for the first column of the Data source. I.e. the Name list in our example. 
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• In the Value field enter $(Document.Age,0). 

 

• Create the second index field and name it Age. 

• Click the down arrow next to the Data source field, and select the data source you created. 

In our example DataSource. 

• Enter “:1” behind the Data source name: DataSource:0. 

:1 stands for the second column of the Data source. I.e. the Age list in our example. 

• In the Value field enter $(Document.Name,1). 

 

Test the results 

• Switch to Navigation mode and scan some documents. 

• Select a name in the Name field. 

The correct corresponding Age should be displayed. 

• Or select an age in the Age field. 

In this case the correct corresponding Name should be displayed. 
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How to automatically rename a batch or documents when fields are 

changed 
To automatically rename a batch or document when its fields are changed, use the $() dependency 

function. 

E.g. ?(IsNullOrEmpty(Batch.Name),"",$(Batch.Name) + " " + $(Batch.FirstName)) 

This means that this naming formula depends on two fields: Batch.Name and Batch.FirstName. In 

other words, the naming formula must be reevaluated as soon as the fields Batch.Name or 

Batch.FirstName are manually changed. 

Note: the naming formula is evaluated only if the field Batch.Name is not null or empty. If this field is 

null or empty, the default batch or document name will be used. 

 

How to Use Watched folders 
To define a watched folder, go to Designer > Properties, specify an input folder (e.g. C:\input) and 

assign the Capture activity to the Service. 

Note: no add-on is required to do the Capture via the Service. Only to have the Export done by the 

Service the Background Processing add-on is required. 
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In Navigation mode, click Open to validate batches captured by the Service. 

Note: in order to create one output file per input file when working with Watched Folders, click the 

Wizard icon next to the Condition field on Batch level and select On every file. 

 

Not doing so will result in merged files. E.g. 5 PDF files of 2 pages will become one PDF file of 10 

pages. 

Signals 
Signals are used to secure the import/export of documents scanned with one project and exported in 

the watched folder of another project. 

Create a new project and define a Path for the Ouput and the Signals. 

 

When all the PDF documents are exported, a signal file is created in the folder C:\signals. 

Now, create another project and define a Watched Folder. 
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A subfolder (e.g. Batch 1) of the watched folder (C:\input) will be processed only if the signal folder 

(C:\Signals) contains a signal file with the same name (e.g. Batch 1). 

How to Do Background processing 
To export batches in the background, go to Designer > Properties and assign the Export activity to 

the Service. 

Important: to do so, the Background processing add-on must be acquired and activated. 

 

In the Navigation pane, click Process to send batches to the Service. 

To follow the status of all the batches, click FILE > Manage.
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How to Share Projects 
Install IPSxServer to share projects, batches, users and groups across multiple workstations. 

Note: a “normal” IPS 10 activation code is needed. 

Export the Project from a workstation. 

 

Import the Project into the IRISPowerscan Server. 

 

Note: in order to update a shared project, you have to export the modified project from an 

IRISPowerscan workstation and re-import it into the IRISPowerscan Server. 

On each workstation, go to FILE > Info > Generalities and connect to the IRISPowerscan Server. 

 

Note: the Central Management add-on must be activated on each workstation. 
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How to Use Logs in IRISPowerscan 10.4 and earlier 
Only experts should enable the logs!  

IRISPowerscan 10 
Open C:\Program Files (x86)\IRISPowerscan 10\IRISPowerscan.exe.config with NotePad.exe 

Edit the <system.diagnostics> node as follows: 

<system.diagnostics> 
  <switches> 
    <!-- TraceLevel defines the level of tracing 
       "0" Off, 
       "1" Error: gives only error messages, 
       "2" Warrning: gives errors and warnings, 
       "3" Info: gives more detailed error information, 
       "4" Verbose: gives verbose trace information --> 
    <add name="TraceLevel" value="4"></add> 
    <add name="SourceLevel" value="All"></add> 
  </switches> 
  <sharedListeners> 
    <add name="Console" type="System.Diagnostics.ConsoleTraceListener" initializeData="true"/> 
    <add name="LogFile" type="System.Diagnostics.TextWriterTraceListener" 
initializeData="c:\temp\IPSx.log"/> 
    <add name="EventLog" type="System.Diagnostics.EventLogTraceListener" initializeData="I.R.I.S."/> 
  </sharedListeners> 
  <sources> 
    <source name="IPSx" switchName="SourceSwitch"  > 
      <listeners> 
        <add name="LogFile"/> 
      </listeners> 
    </source> 
  <trace indentsize="4" autoflush="true" useGlobalLock="true"> 
    <listeners> 
      <add name="Console"/> 
      <add name="LogFile"/> 
    </listeners> 
  </trace> 
</system.diagnostics> 

 

IRISConnect 
Open the Registry (regedit.exe) 

Add a String Value called “Logs” in the IRISConnect registry key. 

 

If the IRISConnect key doesn’t exist, create it yourself. 
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How to use logs in IRISPowerscan 10.5 
To access the logging features, click File > Info > Generalities > Reporting. 

When full reporting is required select All messages in the Application logging and the Service logging 

drop-down lists. 

Note: when you select All messages in the Service logging drop-down list, the application must be 

restarted. 

You can then use the Export diagnostic data button to export and save all your traces. 

 

To export diagnostic data, click the Export diagnostic data button and select which data you wish to 

export: 

• Project: exports the project settings. 

• Image cache: exports the images that are visible in the Viewer. 

• Extended logs: exports Windows Event Logs. 
Logs are stored in C:\ProgramData\IPSx\LocalProjects\Logs. 

Note: if no project is open when you click Export diagnostic data, only the Extended 

logs option is available. 

 

• When you are done, click OK. 

• An Export window now opens. 
Name your project and click Save to save it as .zip file. 

• A second Export windows now opens to save the log file. 
Note: if you selected Extended logs, it may take some time for all the data to be gathered. If 
you did not select Extended logs, a basic log file will be saved. 
Name the log file and click Save. 
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Send email on error: select this option if you want the user to receive a warning email when a 

project is on error in a fully automatic configuration, i.e. when the scanning, validation and export 

are done by the Service or Server. 

Batch on error: select this option if you also want the same user to receive a warning email when a 

batch is on error. 

Enter the recipient in the To field. 

Enter a recipient in Blind Copy in the CC field. 

Enter the Host name and Port number. 

Set the Timeout time after which IRISPowerscan stops trying to send the email. The default time is 60 

seconds. 

If necessary select Use SSL to use a Secure Socket Layer. 

Enter your User name and Password. 

When you are done, click Send test to send a test email. 

Note: when using IRISPowerscan Server the same Reporting settings must be configured inside the 

IRISPowerscan Server application. 

How to Use XMailFetcher with IRISPowerscan 

Installation and Configuration of XMailFetcher 
Preliminary Note: you need Administrator rights to the system on which you install and configure 

XMailFetcher. 

Step 1: Install XMailFetcher 

To install XMailFetcher, double-click XMailFetcher.exe. 

Step 2: Activate XMailFetcher 

Start XMailFetcher. You are prompted to activate it. Send your ID to register-DE@iriscorporate.com. 

You will receive the Activation key in return. Enter it in the required field. 

Important: do not close the XMailFetcher application. Otherwise your ID will change. 

Step 3: Configure XMailFetcher 

Click Settings. 

 

mailto:register-DE@iriscorporate.com
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• Select your account type from the Account-Type list. 

• Fill in all the fields that are required for the selected account type. 

• Enter an Output-Directory. 

This is the folder to which your emails will be sent. This folder must be used as Input folder 

when configuring XMailFetcher as Source in IRISPowerscan. 

• If all settings are correct this is indicated at the bottom of the screen. 

• To test the account’s connection, click Test Account. 

 

Now configure XMailFetcher to run as a Service. To do so, you need to configure at least one account 

for fetching emails: 

1. Click Global Settings. 

2. Enter a user account and password in the indicated fields. 

Then click the Test account button that appears. 

Note that this account requires administrator rights to the Operating System you are 

working on. 

3. Click OK to close the Global Settings. 
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4. Close all dialog boxes of XMailFetcher. 

5. Now type Services.msc in the Windows Search field. 

 

6. Scroll down to XmailFetcherService in the list. 

7. Right-click it and click Properties. 

8. In the Startup type list select Automatic. 

9. Click Apply to apply the settings. 

 

10. Click Start to start the service. 

For detailed information on the configuration see the complete XmailFetcher User Guide. 

Configuration in IRISPowerscan 
To add XMailFetcher as Source, go to Designer > Properties and click the plus sign next to Sources. 

Select XMailFetcher as Input Source. 

Select the Path from which you will scan. This must be the Output-Directory folder you configured in 

the XMailFetcher application. 
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Scanning 
Return to IRISPowerscan and scan from within the XMailFetcher Project you configured. Your emails 

are now inserted into IRISPowerscan. 

Tip: to check the processes in XMailFetcher, start the application. Check the activities in the 

main window. When an email has been converted, the following activity is displayed: 

Converting MailBody to Multipage TIFF done.
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How to Parse QR Codes 
Here we use an example to explain how to parse a QR Code using Scripts. 

Import the following image into an IRISPowerscan project: 

 

This image contains a QR code that indicates the document type and the service: 

“DocType=Inv;Service=03”. 

 

 

• Create a Data Extraction zone for the QR Code:  

o Go to Designer > Images. Add the image above. 

o In the Designer Explorer click Operations > Data Extraction. 

o Draw a frame around the QR code, select Barcode as Type and click Next. 

o Name the zone QRCode and click Finish. 
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• Now go to the default Document and create three index fields:  QRCode, DocType and 

Service. 

 

• Enter Image.QRCode in the Value field of QRCode. 

• Enter the following script in the Value field of DocType: 

SubString(Image.QRCode, (IndexOf(Image.QRCode, "DocType=")+8),3) 

This means its value is obtained by taking the SubString of 3 characters that follows 

the label “DocType=” in the QR code. 

 

1. Enter the following script in the Value field of Service: 

SubString(Image.QRCode, (IndexOf(Image.QRCode, "Service=")+8),2) 

This means the value is obtained by taking the SubString of 2 characters that follows 

the label “Service=” in the QR Code. 
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Tip: click the pencil icon to open the Expression Editor to see the behavior of this 

script on the example. 

2. Return to Navigation mode and click Rescan. 

The result is that the Document index fields DocType and Service contain the respective 

values “Inv” and “03”, which have been extracted from the QR Code. 
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How to use Anchor Points Detection 
By means of Anchor Points Detection you can make sure that recognition zones are positioned 

correctly, and therefore recognized correctly, even if the scanned images have shifted. 

In a sense, Anchor points function the same way as boat anchors do; they keep something in place. 

Note that distortions cannot be corrected in IRISPowerscan, only shifts. 

Important: IRISPowerscan requires bitonal images to recognize Checkmark zones and Anchor shapes. 

If you are scanning color images, make sure to add the Binarize operation as Image Processing 

Operation. 

 

What exactly is an anchor point?  
An anchor point is made of the intersection of 2 lines. The various possibilities are the following: 

• Top left corner 

• Top right corner 

• Bottom left corner 

• Bottom right corner 

• Cross 

• Edge bottom 

• Edge left 

• Edge top 

• Edge right 

 

Note that you need at least 1, and ideally 4 or more anchor points on an image. 
 

Note: Black squares are not supported as Anchor shapes. 
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Example of how Anchor Points Detection works 
• In IRISPowerscan click FILE > Open. 

• Double-click the Anchors project to open it.  

• Click the Designer tab in the bottom left corner to switch to Designer mode. 

• Expand Operations > Data Extraction in the Designer tree. 

• Notice that two anchor points have been defined. 

 

• In the second Data Extraction set, one Text zone is defined. 

Without the Anchor Points, this Text zone would not be recognized correctly if the pages 

were to shift. 

 

• To test this, uncheck the first Data Extraction set containing the Anchor Points. 

• Switch to Navigation mode. You will be prompted to save the project. Click Yes to do so. 

• Then click Scan. 

When the scanning is complete, click each Document and check the Patient ID index field. 

You’ll see that in most cases it has not been recognized correctly. This is because the sample 

images have shifted. 

 

• Return to Designer mode and select the first Data Extraction set again. 

• Return to Navigation mode, delete the batch you scanned and click Scan again. 

You’ll see that the Patient ID index field is recognized correctly. 

 



 

 34 

How to create Anchor Points in IRISPowerscan 
 

Preliminary note: in this section we assume you already have images or paper sheets that contain 
objects that can be used as Anchor Points.  
 
If you do not, you can use the Document Generator Tool to create Anchor Point Documents. You can 
find it in All Progams > IRISPowerscan 10 > Tools > Document Generator. 

Image Processing Requirements 

Anchor Points Detection is applied on binarized (black-and-white) images. If you are using color 

images, apply Binarize as Image Processing Operation.  

To do so, click Wizard > Add an image processing operation > Binarize. If you do not, a 

default binarization will be applied. 

The image on which you are designing the Anchor Points should be of perfect design, so not skewed 

or having been deskewed. 

To avoid that the images you will be scanning are skewed, apply Deskew as Image Processing 

Operation. 

Positioning Recommendations 

1. Spread out the Anchor Points evenly on the entire image. If you locate all the anchor points 
in the same area, the system will not be able to locate the information precisely. 

 

2. Avoid perfect symmetry. It would make document reorientation impossible. 

 

3. If the image content is grouped into tables and squares, the intersection of their lines can be 

used as anchor points, provided they are 2 pixels thick. 
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4. Do not position an anchor point close to an angle that could be interpreted by the system as 
an anchor point.  

5. Do not use any dotted lines to design an anchor point. 
6. Do not use grey shadowed areas near the anchor point. 
7. Make sure the 2 lines actually touch each other and form an intersection. 

 

Creating Anchor Points in IRISPowerscan 

• Add your Anchor Points image to Images in the Designer tree. 

• Expand Operations and select Data Extraction. 

 

• Draw a frame around the area you want to use as Anchor Point. 

• Select Anchor point (shape) and click Next. 

• Determine the Options: 

o Enter a Name for the Anchor Shape zone. 

o Line length: minimum length of a line to be considered. 

o Line thickness: maximum thickness of a line to be considered. 

o Distance: minimum distance from the image border (in order to avoid detecting 

image borders as anchors.) 

o Shape: select the expected shape of the anchor point. 

• When you are done, click Finish. 

• The Anchor Shape Zone is now created on the image. 

• Click the Target icon ( ) to position the cross in the center of the circle. 

This way the data extraction zone is centered on the detected anchor. 
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Note: the Wizard ( ) is not used here. 

 

Note: the red circle means an anchor has been detected. The green cross indicates 

the center of the Data Extraction Zone. 

• Now repeat these steps for the other Anchor Points. 

What happens during processing? 

During processing IRISPowerscan looks for any anchor of the indicated type in the data extraction 

zone. 

For each anchor that is detected, an offset between its actual position and the position at design 

time is computed. Out of that, an average offset is computed. This average offset is used to shift all 

the other extraction data.
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How to use Checkmark Detection 
It is now possible to create Checkmark zones in IRISPowerscan. Their value can be checked (1), 

unchecked (2) or cancelled (4). 

The values of Checkmark zones can be used to fill in Index fields by using Expressions. How to do so 

will be explained below. 

Important: IRISPowerscan requires bitonal images to recognize Checkmark zones and Anchor shapes. 

If you are scanning color images, make sure to add the Binarize operation as Image Processing 

Operation. 

Creating Checkmark zones in IRISPowerscan 
• Create a new Project and switch to Designer mode. 

• Right-click Images and add a sample image that contains the checkmarks you want to use. 

Important: the checkmarks on the pages you will be scanning must be located at the 

exact same positions as on the sample image. Otherwise the recognition will not 

work. 

Note that it is recommended to use Anchor Points Detection combined with 

Checkmark Detection, in case the scan should shift a little. 

• Expand Operations and select Data Extraction. 

 

• Draw a frame around the area you want to use as Checkmark. 

• Select Checkmark shape and click Next. 

• Determine the Options: 

o Enter a Name for the Checkmark zone. 

o Min Threshold: This is the percentage of the zone that must be filled in order for the 

zone to be considered as checkmark zone. The default Minimum threshold is 30 %. 

o Max Threshold: If the zone is filled more than the Maximum threshold, the zone will 

be considered as crossed out, instead of checked. 

 

o Remove noise: Select Remove noise to have IRISPowerscan to remove noise pixels 

from the zone. 

o Sample: Adding a sample is recommended to increase the recognition accuracy. 

Without a sample, IRISPowerscan examines the entire data extraction zone. With a 

sample, the pixels that are taken into account are only those inside the checkmark 

zone (checkmark included). 



 

 38 

 

• Click the Wizard icon on the checkmark zone. 

 

• Determine the value of the checkmark zone.  

The value of a checkmark zone can be 1 (checked),  2 (unchecked) or 4 (cancelled). 

 

• Repeat these steps for all the checkmark zones you want to use. 

Filling in Index fields based on Checkmark zone values 
Once you have created the required Checkmark zones and attributed a value to them, their value can 

be used to fill in index fields. 

How this works will be explained by means of the Checkmarks Demo project in IRISPowerscan. 

• In IRISPowerscan click FILE > Open. 

• Double-click Checkmarks to open the project. 

• Click Scan to scan the demo images. 

• Notice that the Document index fields are filled in. 

 

• Switch to Designer mode and expand Pages > 0101 > Operations > Data Extraction. 

• Two checkmark zones have been created for Question 4 C. 

The value of these checkmark fields were used to determine the value of the Index field 4C 

(cf. image above). 
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• Select a Checkmark zone and click the Wizard icon to check it value. 

You’ll see that Yes has the tooltip “checked” and No “unchecked”. 

 

 

• The values of these 2 checkmark zones are used in an Expression to determine the Value of 

Index field 4C. 

• To check this, expand Documents > 0101 > Fields > 4C. 

Examine the expression: 

The value is “Yes” if the checkmark zone Image.4C_1 is checked (1) or the value is “No” if the 

checkmark zone Image.4C_2 is checked (1). 

Note: the value of a checkmark zone can be checked (1), unchecked (2) and 

cancelled (4). 

 

Of course, much more complex expressions can be used. Check for instance the Value of the Race 

field.
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How to use Debookletting 
The Debookletting feature allows you to scan books faster. Instead of scanning two pages of a book 

at at time, remove the staples from the book and feed the entire batch of sheets into a duplex 

scanner. By means of the Reorder operation you can reorder the scanned pages in the right order. 

Pages may either be Landscape or Portrait oriented. 

Notes: 

The Debookletting feature only works on Document level. It is not possible to reorder pages across 

different documents and batches. 

The Debookletting feature only works on an even page count. 

This is the only use case in which the Reorder operation can be used. The Reorder tool on the Edit 

tab of the main toolbar however also has other functions. See the corresponding section in the User 

Guide for more information. 

 

Requirements: 

Paper sheets must be of A4 or A3 size. 

Your scanner must scan in Duplex mode. 

 Attention: do not use the Debookletting feature in Simplex mode when using a real scanner,      

              for this will not work. When scanning from folders, the Duplex mode is not required. 

Split horizontally must be selected as Arrangement option in the Sources settings. 

The Debookletting can either be done automatically via the Reorder Operation or it can be done 

manually via the Reorder tool. 

Automatic Reordering 

• Open a Project and click Wizard. 

• Select Add an operation > Reorder. 

• Switch to Designer mode and expand Operations > Reorder. 

• Select Automatic and then select the Mode: 

Important: in Automatic mode the reordering only occurs at the end of a document. This has 

implications for projects in which separators are used. In such projects the separator must be 

the first image that comes after the page arrangement. 

o Cover first: if the cover page will be fed first into the scanner. 

o Cover last: if the cover will be fed last into the scanner. 
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• Remove the staples from the book you want to scan and disassemble the sheets. 

Important: keep the sheets in the right order and do not mix them up. If the order of the 

sheets is mixed up, you need to use OCR-based reordering (explained below). 

• In Designer mode click Properties. 

• Now select the Source you will be using. 

o Make sure the Duplex scanning mode is activated. 

o Select Split horizontally as Arrangement.  

 

Example with Folders as Source 

• Scan your documents. They should be reordered correctly. 

Important: take into account the direction in which the text is read by the scanner. In 

some cases you may need to apply a Rotate operation in IRISPowerscan. 

Manual Reordering 

• Remove the staples from the book you want to scan and disassemble the sheets. 

Important: keep the sheets in the right order and do not mix them up. If the order of the 

sheets is mixed up, you need to use OCR-based reordering (explained below). 

• In Designer mode click Properties. 

• Now select the Source you will be using. 

o Make sure the Duplex scanning mode is activated. 

o Select Split horizontally as Arrangement.  

• Scan your documents. 

Important: take into account the direction in which the text is read by the scanner. In 

some cases you may need to apply a Rotate operation in IRISPowerscan. 
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• In the Navigation tree select the Document that has been created. 

• Then click the down arrow next to Reorder and select Cover first or Cover last depending on 

how you scanned your pages. 

 

Tip: in case you selected the wrong option, use Ctrl+Z to undo the reordering. 

OCR-based Reordering 

If your pages are completely mixed up, you can always use OCR-based reordering, based on the page 

number. 

Important: the same requirements apply as for the other Reordering modes. 

• Add one sample page that contains a page number. 

• Create a Data Extraction zone around the page number. 

• Click Wizard > Add an operation > Reorder. 

• Switch to Designer mode and expand Operations > Reorder. 

• Select OCR based and then select the zone you created from the drop-down list. 

 

• Scan your pages in Duplex mode. 

If the page numbers are recognized correctly, the pages should be reordered correctly as 

well. 

Important: the number of pages you scan in a batch must be even. An odd number of 

pages cannot be reordered correctly.
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Using Confidence Levels on Index Fields 
IRISPowerscan always computes a confidence level for Data Extraction zones. The Confidence level is 

shown in the Tooltip of the Data Extraction Zone. 

 

When Data Extraction Zones are linked to Index Fields, you can apply a Confidence Condition to the 

Index Field. This means that if the confidence in the recognition accuracy is below an indicated level, 

the Index Field will be flagged as inaccurate. 

Note that the Data Extraction Zones must be of the type Text, Hand-Print or Barcode. 

To use a confidence level on an Index field: 

• Create a Data Extraction zone of the type Text, Hand-Print or Barcode. E.g. Zone1. 

• Link it to the default Index field Field1 of the default Document type. 
To do so, enter Image.Zone1 as Value. 

• Then enter the Confidence Condition. 
In our example Image.Zone1.Confidence>50. 
In this case the field will be flagged as inaccurate if the confidence level of the Data 
Extraction Zone Image.Zone1 is below 50. 
The confidence value must be an integer between 1 (very low confidence) and 100 (very high 
confidence). 

 

• The Document and Batch containing the inaccurate index field will also be flagged as 
inaccurate and will require validation. 

• Do the Validation and modify the results if necessary. 

Note however that the color of the index field does not change, even when you have 

corrected it.  

 

Note: 

Confidence levels can also be applied on Page, Document, and Batch level. 

The confidence level of a page is stored in the variables: 

• Page.Confidence 

• <Page.Type>.Confidence 
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The confidence level of a document is stored in variables: 

• Document.Confidence 

• <Document.Type>.Confidence 

The confidence level of a batch is stored in variables: 

• Batch.Confidence 

• <Batch.Type>.Confidence 

 

How to keep expressions with unknown variables from being 

processed 
In IRISPowerscan unknown variables are replaced by an empty string. For instance, if the variable 

Page.Index is unknown or not found in the expression “Page (“ + Page.Index + “)”, then the 

expression will be evaluated as “Page()”. 

To avoid that expressions which contain unknown variables are evaluation put a “?” in front of the 

expression and place the expression between parantheses.  

For instance, ?("Page (" + Page.Index + ")"). 

How to synchronize Date formats between IRISPowerscan, your 

Windows System Account and Windows User Account 
In projects where the Export is handled by the Service, and where you add the the Date to the 

Output path (by using the variables System.Today or System.Now) problems may occur when the 

Culture of your Windows System Account does not correspond to the language of your Windows 

User Account. In some cultures dates are formatted as dd/mm/yyyy while in others they are 

formatted as mm/dd/yyyy. 

 

Export handled by Service 

 

Date added to Output Path 

To synchronize both cultures: 

• Go to Control Panel > Region and Language > Administrative. 
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• Click Copy settings. 

 

• In the Window that appears select Welcome screen and system accounts. 

• Click OK to confirm. 
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How to obtain a Reset Code 
If you acquired a version of IRISPowerscan that includes a professional connector, you are prompted 

to select the connector of your choice after you have activated IRISPowerscan. 

The selection of the connector is final. If you accidentally selected the wrong connector, you need to 

obtain a Reset Code. 

To do so: 

• Click File > Info > Features. 

• Click Copy to clipboard in the bottom right corner. 

• Paste this info into an e-mail and send it to activation@iriscorporate.com. 

• Explain in the e-mail that you need a Reset Code. 

• Once you have obtained the Reset Code, go to File > Info > Features and click Activate. 

• Enter the Reset Code in the Activation Code field and click Activate. 

• Restart the application when prompted. 

• Next time IRISPowerscan starts you are again prompted to select a connector. 

• Make sure to select the right connector this time. 

How to apply Image Filtering 
When scanning multiple streams to IRISPowerscan you can now choose which stream must be 

displayed and which stream must be exported for every image. 

Example of how it works 

You are scanning both the black-and-white stream and the color stream of your images to 

IRISPowerscan. You want the Color stream to be displayed for all Pages except for Page 2, and you 

want only the checked black-and-white image to be exported. 

• Scan your images in multistream to IRISPowerscan. 

• Click the View tab. 

• Click the down arrow-beneath Show and make sure Color and Black-and-white are available. 

 

• Select Color. 

The Color stream of your images is now displayed. 

• Select the Page of which you want to display the Black-and-white stream. In our case Page 2. 

• Click the down arrow beneath Check and select Black-and-white. 

Note: you can also right-click on an image, point to Check and select the required 

stream for the selected image. 

mailto:activation@iriscorporate.com
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• A checkmark is placed on Page 2 in our example and Page 2 is displayed in Black-and-white. 

 

• To filter the output, switch to Designer mode and expand the Output type you will be using. 

• Enter Image.IsChecked as Condition. 

In this case only the checked image will be exported. 

 

• Click Process. 

Only Page 2 should be exported to the configured destination. 

Note that you can also use other Conditions of course. For instance Image.IsBest. This Condition is 

evaluated as true if the corresponding image/stream is checked and if the corresponding 

image/stream has the highest bits per pixel for that particular page. Or use Image.IsVisble to export 

only the visible (displayed) images. 
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